Comments

Log in with itch.io to leave a comment.

found this bug in the map. Can I be a tester?

Thanks for finding that. I always appreciate when someone finds one of those. There are still far too many. >.>

But, we're always looking for more testers. Right now, we're looking for testers mostly to find bugs that we are unaware of and to test the newest content as it comes out to: find bugs, provide opinions, and help with balancing. 

Balancing and opinions are the two biggest areas that we're looking into right now for play testers. 

If this interests you, you can send an email to me at cloudsofglassgames@gmail.com or respond here with your email address so we can get everything set up and working.

You are welcome, I will send an Email instead. I don't want random people Emailing me. I want to give you an heads up that I have dysgraphia. It's a writing learning disability, so my grammar will be crap. LOL

Good thing I have grammarly for the spelling, and small grammar.

(2 edits)

when i download it the file doesn't work

edit: ok i got the game working it's not that bad but the optimization needs a little work.

edit again: it seems it doesn't want to load me in the world anymore i may have broken it

Optimization is something that we've been trying to get right for a while now, kinda of an ongoing battle to make it all work.

Our play-tester has been saying that he has been having problems occasionally with loading as well. Out of curiosity, are you running a 32 or 64 bit version of Windows?  

hey thanks for responding to my comment. i'm running on the 64 bit i think.

Hmm. I wondered because I'm fairly sure that it was something to do with distance fields that were causing crashes on our play-tester's computer as his is a 32 bit. I just yesterday actually got rid of the distance fields themselves in the name of optimization. It makes creating bodies of water more time consuming, but it is what it is. 

Did the game crash at all? Or just fail to load?

I've also been experiencing random load failure, even when working in engine. It keeps outputting an infinite loop, but the crash logs don't actually point me to anything; just to an 'unknown function.' I've got some ideas as to what it could be, but I've yet to actually pin down the source.

Anyway, enough rambling from me. :p

the game never crashed ( yet ) it just fails to load and then i get this weird broken map camera where i'm halfway thru the ground. recently i found some weird thing where this little menu shows up and locks the screen but i can't get rid off it. (i can't get a good pic of the loading screen freeze.)

I had found that bug too and I think I already fixed it, or I have decreased the frequency it occurs, at least. I'm not 100% what was causing it, but it hasn't happened to me since I played with the code for the player's home. And I'm not 100% sure, but it seems that I have fixed the loading issues on my end as well. 

I intend to throw a hot-fix up later today/early tomorrow since those two bugs in particular are pretty nasty, game-ruining experiences. 

I appreciate the help, by the way. If I could ask, how is the actual gameplay so far? Is it fun? Are there any areas that definitely need improving?

I like to think it's fun, I enjoy as does our play-tester, but we've both been playing it for years now through hundreds of iterations, so our vision could just be tinted. :/